Invalid recaptcha

Home Forums Plugin Support Invalid recaptcha

This topic contains 17 replies, has 5 voices, and was last updated by  sourov amin 4 months, 1 week ago.

Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • #9051

    aski
    Member

    Hi,

    I just discovered that user registration using recaptcha does not work anymore.
    It always says: Invalid recaptcha.

    I searched around here and found a solution, inserting a snippet into functions.php.
    Tried that, but it did not work.

    Any hints?

    #9057

    sourov amin
    Moderator

    Hello,

    Can you set a temp admin and send the credentials to ‘support(at)user-meta.com’ so we can check the issue closely.

    And sorry for the late response.

    Thanks.

    #9060

    aski
    Member

    Hi,
    I will set up a temp admin using password:
    The rest I’ll send you via email.
    Please be aware this is a live site when you do some testing.
    Thanks!

    #9065

    aski
    Member

    Hi Sourov,
    any news on this?
    Thanks,
    Alex

    #9108

    Hi Sourov,

    I also experienced the same problem, the registration form is always displaying Incorrect captcha code.

    This happens after I update to PHP 7.3

    Thanks.

    #9154

    I’m a new user, just getting this plugin set up.

    I am having the same problem. Getting this console error when I try to log in:
    Error: Syntax error, unrecognized expression: Call to a member function validateCaptcha() on null

    This is on my login page – which does NOT have a recaptcha field! I do have one on my registration page, and that is also not working. The form setting for that field is set to “Only on registration page”, but changing that makes no difference to either page.

    (EDIT – I have tried removing captcha from the registration page – but the same error happens, even though I have no recaptcha on any form. I have also tested (using a different plugin) my recaptcha keys. They are correct.)

    • This reply was modified 6 months, 2 weeks ago by  Nigel Osborne.
    • This reply was modified 6 months, 2 weeks ago by  Nigel Osborne.
    #9157

    sourov amin
    Moderator

    Hello Nigel,

    We are checking the issue and will let you know ASAP.
    It would be helpful if it is possible to make a temp admin in your site
    and share the credentials at support(at)user-meta.com.

    Thanks.

    #9158

    I have created the temp admin account. Details in email.

    #9161

    sourov amin
    Moderator

    It seems, we have an issue in the recent User Meta Pro version 2.0.1 with the custom login form under certain conditions. We will fix this in the next release in no time.

    But the default login form of User Meta Pro is working without any problem and it solves the latest issue in this thread. So for now, this one is marked as resolved.

    #9186

    HI, i have a client still having this issue.

    #9188

    sourov amin
    Moderator

    Hello Christopher,

    Is your client using the latest version of UMP (2.0.2)?
    If not, please upgrade to the latest version.

    #9196

    Hi, yes we’re using the most recent version and still having the error. I’m not sure how to troubleshoot. I’ve tried re-setting the keys, using different keys and have had it turned off but am now getting a lot of fake sign ups.

    #9199

    sourov amin
    Moderator

    Hello Christopher,

    Are you having this re-captcha problem in a custom login form or any form you are applying to?
    Which version of re-captcha you are using?

    #9200

    hi,

    yes it’s a custom form. i’ve tried both captcha’s.

    #9201

    sourov amin
    Moderator

    Please try the Dev Version from https://user-meta.com/downloads/

Viewing 15 posts - 1 through 15 (of 18 total)

You must be logged in to reply to this topic.