Avatar Uploading Failed

Home Forums Bug Reporting Avatar Uploading Failed

This topic contains 9 replies, has 5 voices, and was last updated by  Khaled 8 months, 3 weeks ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #8384

    In making the upgrade from 1.1.8rc1 to 1.3, we have lost the ability to upload image files for the avatar field. After trying to upload we see the file name and size but not the image. In the code it looks like this:

    <li class=” qq-upload-success”><span class=”qq-upload-file”>anon.jpg</span><span class=”qq-upload-size” style=”display: inline;”>8.2kB</span><span class=”qq-upload-failed-text”>Failed</span>

    So that “Failed” message isn’t even showing. I’ve checked the permissions on the uploads/files folder, I’ve disabled AJAX uploading on this file (though that doesn’t seem to change anything), and I’ve rollbacked to the previous version, but that removes a bunch of other fields that show up in 1.3. So we’re stuck. Any suggestions?




    Hi Mark,

    With v1.3, please try file upload field. Just want to see if the issue is in avatar or overall file uploading field.



    I added a file upload field and that also failed in exactly the same way as the avatar field. This is all in the backend profile, BTW. On the frontend the avatar field seems to work fine.

    Thanks, Khaled.



    Hi Mark,

    Is it possible to set a temp admin account on your site so that I could have a closer look in the issue? You can use support(at)user-met.com for admin access.



    Sure, I can do that, but before I do is it possible for you to open up our license temporarily to allow installation on our dev domain (dev.lawpact.org)? That way, you can experiment without worrying about changing anything on our live site.


    Hi, Khaled.

    I started looking into this myself and I found the issue. Here’s the AJAX request for uploading a file in the last version that worked for us:


    And here it is in the newest version that is not working:


    The difference is that in the new, non-working version the form_key parameter is ‘undefined’ whereas in the working version that parameter is blank. And the reason for that is because no um_form_key attribute is added to the avatar field wrapper div in the newest version. The uploading code is pretty much the same between these versions except for the new File class in models/classes/Field so you might want to look into a fix there.

    But what I did to fix it for the time being was to change line 232 in user-meta.js:

    var formKey = jQuery(this).attr(“um_form_key”) || ”;

    And comment out the redundant assignment on line 242. This passes the form_key attribute as blank instead of ‘undefined’ and the upload succeeds.

    Do you know a way to fix this through the plugin settings? Or will there be a fix in an upcoming version?



    Hello, I am having a similar issue uploading an image using the avatar field using version 1.3. Any progress on this issue?
    Thanks, Brian



    Same there. Issue. I have been forced to change and replace avatar by picture and replace after the field using a function.


    I am having the same issue. The filename displays for avatar as well as for fileUpload – but the actaul image does not display. I have used the settings you recommned in the documentation.

    You can see this at http://www.staging3.smartstart.co/ – the form is located just below the banner picture

    Please advise. Thanks!


    • This reply was modified 9 months, 1 week ago by  Marko Schmitt.


    Hello Everyone,

    Please try our dev version. The issue has been solved in the dev version.
    @Mark Figlozzi, Thanks for your inspection.


Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.