Remove Activation Link from Admin Notification

Home Forums Plugin Support Remove Activation Link from Admin Notification

Tagged: ,

This topic contains 3 replies, has 2 voices, and was last updated by  visualharmony 1 week, 3 days ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #8853

    Hello,

    I am using a custom role for activating user accounts. However, since this custom role is not a site ‘admin’, when they click the activation link, it says “not an admin” at the top of the users page. So, I am manually sending them to the Pending Users page and from there they can activate. So, I don’t want the activation url to be added to my custom html email. However, it keeps adding itself to the bottom of the message even though I am not using the %activation_url% tag anywhere in the message. Please let me know how I can disable the activation link from appearing in my emails.

    Thank you,
    Jack

    P.S. the version is 1.4.2 but that option was not available under “User Meta Version” when posting this.

    #8854

    Actually, I figured out that if you add the %activation_url% link to the message and hide it with CSS (see below), it will not automatically append it to the message.

    <span style="visibility: hidden; display: none; height: 0px;">%activation_url%</span>

    So, I just did that and that’s good enough for now. However, it would be best if it didn’t get added at all unless we add that tag.

    Best,
    Jack

    #8855

    sourov amin
    Moderator

    Hello,

    This is a little unfamiliar situation for activating users with a non-admin role. Activation URL is by default added to make sure the link is there even if someone missed it in the settings. But thank you for letting us know the issue. We will consider this in the future release.

    Best Regards.

    #8856

    Hello,

    No worries. It is working well enough for me now. I created a separate role and gave it permissions for managing users. That allows them to activate/deactivate new users who have registered through the site without giving them full admin access.

    Thank you,
    Jack

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.